即日起在codingBlog上分享您的技术经验即可获得积分,积分可兑换现金哦。

dpkg:- error processing package javascript-common (–configure):- while using apt-get command

栈溢出 Rahul Satal 117℃ 0评论
本文目录
[隐藏]

1.原始问题:dpkg:- error processing package javascript-common (–configure):- while using apt-get command

I was trying to reinstall my apache 2 after un-installing it. But on installing it using command-
sudo apt-get install apache2

i am getting error-

Error while installing apache2

rahul@rahulpc:~$ sudo apt-get clean && sudo apt-get autoclean
[sudo] password for rahul: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
rahul@rahulpc:~$ sudo apt-get --reinstall install apache2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libblas3 liblinear-tools liblinear1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 474 not upgraded.
1 not fully installed or removed.
Need to get 87.4 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://in.archive.ubuntu.com/ubuntu/ trusty-updates/main apache2 amd64 2.4.7-1ubuntu4.4 [87.4 kB]
Fetched 87.4 kB in 3s (28.0 kB/s)  
(Reading database ... 172062 files and directories currently installed.)
Preparing to unpack .../apache2_2.4.7-1ubuntu4.4_amd64.deb ...
Unpacking apache2 (2.4.7-1ubuntu4.4) over (2.4.7-1ubuntu4.4) ...
Processing triggers for ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Processing triggers for ufw (0.34~rc-0ubuntu2) ...
Processing triggers for man-db (2.6.7.1-1) ...
Setting up javascript-common (11) ...
dpkg: error processing package javascript-common (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up apache2 (2.4.7-1ubuntu4.4) ...
/etc/init.d/apache2: 64: .: Can't open /etc/apache2/envvars
/etc/init.d/apache2: 76: .: Can't open /etc/apache2/envvars
ERROR: APACHE_PID_FILE needs to be defined in /etc/apache2/envvars
invoke-rc.d: initscript apache2, action "restart" failed.
Errors were encountered while processing:
 javascript-common
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also when i run command-

sudo apt-get upgrade

i am getting same error,I think i have removed some essential directories while un-installing apache 2 . Anybody please help me to recover the files and to install apache 2.

2.被采纳答案

暂无被采纳答案,请参照下面其他答案。

3.其他高票答案

3.1.第1个答案

Finally i solved the error by running commands-

sudo apt-get clean && sudo apt-get autoclean
sudo apt-get purge apache2
sudo apt-get install apache2

转载请注明:CodingBlog » dpkg:- error processing package javascript-common (–configure):- while using apt-get command

喜欢 (0)or分享 (0)
发表我的评论
取消评论

*

表情